Audiofile Engineering
Wave Editor 1 Beta Appcast
+ Added feature
* Improved/changed feature
- Bug fixed
! Remaining bugs and missing features
1.5.8b2 Apr 02 2013 Download
- resolves an issue where dragging a region from a source file would prepend blank audio when dragged to a destination file
- resolves an issue that occurred with tap-to-click enabled in Mac OS X's trackpad settings
- minor fixes
1.5.8b1 Mar 25 2013 Download
* greatly improves Mac OS X 10.8 (Mountain Lion) support
- resolves an MD5 issue for exported DDP sets
- resolves an issue where downsampling with the iZotope converter would alter the length of files
- various other bug fixes

1.5.7rc2 May 14 2012 Download
- resolved an issue where the AU Validator application would crash
- resolved an issue where exporting files with sample rates lower than 44.1 to AAC would not work
- resolved an issue where 32-bit files created by Max/MSP would not open
- resolved an issue importing dual mono SDII files
- resolved an issue uploading FLAC files to SoundCloud
- improved the interface for advanced options in the Processor
- resolved an issue where saving large wave64 files would cause an application error
- resolved an issue where the SmartEdits List would report the wrong channel count
- resolved an issue where Cut/Copy to New Document would not include removed audio at the start of the file
- resolved a rounding error when Flattening
- resolved an issue where compressed CAF files would open natively
1.5.6b2 Aug 21 2011 Download
NOTE: This build requires Mac OS X 10.6 and an Intel processor. All future builds of Wave Editor are Intel-only. We will no longer be releasing Universal binaries of our apps.

- resolved an issue where MP3 and other non-native files would not import via drag and drop
- resolved an issue where copying and pasting a Wave64 file would generate an application error
- resolved an issue where a file would not save if only the name of a layer was changed
- resolved an issue where "retain unrecognized data" would not function as desired
- resolved an issue where saving a .wedt file with fades as "efficient" would generate an application error
- resolved an issue where a song with no ISRC code in a DDP set would inherit the previous song's ISRC code upon import
- resolves an issue where holding down "s" at launch would not skip plug-in validation
- various bug fixes and improvements
1.5.5b1 Mar 21 2011 Download
- Resolved an issue wherein playback produced overs under certain circumstances
1.5.0b5 Dec 29 2010 Download
- Fixed an issue that prevented users from connecting to SoundCloud
- Resolved an issue wherein flattening layers removed markers
1.5.0b4 Dec 09 2010 Download
- Various bug fixes
1.5.0b3 Sep 30 2010 Download
- Various bug fixes
1.5.0b2 Jul 08 2010 Download
- fixed an error when using the Processor
- fixed an error when saving and opening .wedt files
1.5.0b1 May 27 2010 Download
REQUIRES MAC OS X 10.5 (LEOPARD) OR 10.6 (SNOW LEOPARD)

+ Initial build of 1.5.0, requires Mac OS X 10.5 or 10.6
+ SoundCloud support

1.4.7b1 Apr 08 2010 Download
- Fixed an issue wherein Overview didn't draw properly when opening files as consecutive layers
- Fixed an issue when saving surround files as Wave64 format
- Fixed an issue when opening an AIFF with an empty audio chunk
- Fixed an issue when removing audio interface while exporting to MP3
- Fixed an issue selecting stop when opening consecutive files as SmartEdits
- Fixed an issue dragging an .m4a file onto Wave Editor icon
- Surround file converted to split Wave file now retains proper timestamp information
1.4.6b4 Jan 11 2010 Download
* Improvements to importing AC3 files.
1.4.6b3 Nov 11 2009 Download
- Fixed an issue wherein MP3s would not import when dragged onto the application icon.
- Fixed an issue with new Layers causing playback issues.
1.4.6b2 Nov 05 2009 Download
+ Added FiRe Browser (only works with FiRe 1.3+)
* Fully Snow Leopard compatible
* made the window title of split file formats now show the extension as *
* recognized unusually-formatted 'cue ' chunks in WAV files
- fixed an issue changing the Genre Code in Properties
- fixed an issue using ISRC codes with lowercase letters
- fixed an issue with unnamed tracks loaded from a cue sheet
- fixed a bug moving a SmartEdit from a non-left channel
- fixed an app error that would happen reading a malformed DDP file
- fixed some inconsistencies in writing Broadcast WAVE and iXML time references
- fixed an issue editing the sync time in a region
- fixed an error duplicating an empty layer
- fixed an error importing or loading multiple split scheme files
- fixed an issue with files that would open without a waveform
- fixed an issue with the Speed process working on entire files
- fixed an issue attempting to save an audio selection with master layer effects when a single layer is selected
- fixed an error in an alert when attempting to save a flat file with features of un-flattened files
- fixed cmd-opt-shift double-click on the non-selected waveform
- fixed subtle UI bugs in Snow Leopard
- fixed a rare crash when saving with effects on the Master Layer
- fixed some issues with time display
! removed import support for AC3 files due to licensing issues
1.4.6b1 Aug 10 2009 Download
* added a "Configure..." button to Preferences > Output > Audio Output
* .wedt files and document templates will remember the width of the labels and layers drawer
- fixed an issue opening SDII damaged in a specific way
- Audio File First Aid: able to repair SDII files damaged in a specific way
- fixed some issues with MS Encode & Decode
- fixed an issue dragging links onto a new document containing only links
- fixed a bug flattening multichannel layers with effects
- fixed a few bugs with the Analyzer
- fixed an occasional app error changing crossfades during playback
- fixed a bug selecting the color of a layer while the Color Panel is open
- fixed a visual bug with the playback head on stopped playback
- improved drawing of SmartEdits when zoomed in extremely close
- fixed a bug updating the length in the Info Bar when the length of the audio changes
- moving SmartEdit handles when "Allow Separate Channel Selection" will move all channel-matching SmartEdits
- improved Location Tip positioning
1.4.5b17 Apr 02 2009 Download
- updated iZotope resampler
- updated iZotope MBIT+ dither
1.4.5b15 Mar 20 2009 Download
* made the Save As Template panel a sheet for the appropriate document
- displays an error if the cue sheet export fails
- improved the behavior of selecting and removing/deleting areas defined by or between range labels
- fixed an issue writing split WAV files
- fixed an issue reading "lone" files from a split file format
- added a throttle to drawing the playback head and the playback clock improves GUI performance on plug-ins with meters
- fixed a rare situation that could cause an audio glitch
- iZotope resampler fix
1.4.5b14 Feb 25 2009 Download
* improved loading files with content in the master layer into new or existing documents
- plugged a memory "leak" when splicing SmartEdits
- fixed an issue with autoscroll with looped ranges that were bigger than the displayed waveform
- fixed an issue with certain effects and their reported supported channels
- fixed an issue being able to move the insertion point past the end of a file
- fixed an issue reading empty ISRC codes from DDP files
- fixed an issue saving labels with forward slashes in the names
- fixed an issue updating the info bar elements after analysis was done
! iZotope output converter is not working properly (awaiting fix from iZotope)
1.4.5b13 Feb 06 2009 Download
- fixed a bug entering values into Processor > Change Gain without a leading + sign
- fixed an issue writing files with fades that are readable in 1.4.4 and previous
1.4.5b12 Feb 02 2009 Download
- addressed an issue removing selected audio between ranges
- fixed a crash if an Audio Unit could not be opened because of bad permissions
- fixed an issue with the bars|beats rulers
1.4.5b11 Jan 23 2009 Download
- fixed an issue reading info about Labels drawer columns from template made in earlier versions
- fixed some situations where the items in the Information Bar were not current
- fixed an issue reading some DDP file sets


1.4.5b10 Jan 05 2009 Download
* improved the SmartEdit contextual menu
* improved behavior of effect windows and keyboard shortcuts
- allowed burning to CD-RW discs
- fixed a bug writing CAF files that are little endian format

1.4.5b8 Dec 15 2008 Download
+ Preferences > General > Processing > Use dither (add the appropriate Type II dither to any processing/writing)
+ Cue labels (for Flash)
+ support for cue point XML files for the Flash Video Encoder (import via Load..., export via File > Export > Cues...)
+ native support for Wave64 files
+ background analysis (Leopard only), improves performance in a number of areas
+ Chapter labels (for Podcasts)
+ Export > Podcast
* Import support for voXover files
* Enhanced Support > Screencasts
* Support > Release Notes changed to Support > Versions
* hold down 's' key during start up to skip effect validation
* hold down 'v' key at startup to re-validate all effects
* Labels display options: Labels Drawer > Options... button and View > Options > Labels...
* New Layer display method in Labels Drawer: Current Layer
* more Extend Selection To... commands in Keyboard Shortcuts
* Properties import/export support for AAC, Apple Lossless and Podcasts (uses iTunes property set)
* Waveform selection contextual menus > Add Fade
* Layer table contextual menus > Add Effect
* Background color, overview draws using background color
* Manual does not hide when app goes in background
* added a cancel button to the "paste multiple items" alert panel
* small improvements to the Keyboard Shortcuts panel behaviour
* small improvements to the Generator/Recorder/Meters panel behaviour
* improved the Generator GUI
* improved the Label Well GUI
* small improvements to the selection area GUI
* Time Units are configurable in the Open panel
* added Logarithmic fades
* "CPU Load" item in Information Bar
* Information bar items can optionally show labels and units where applicable (via contextual menu)
* Preferences > General > Playback: Front Document Only, conserves CPU load when many documents open
* more permissive in opening files that are damaged
* Audio File First Aid: drag & drop files
* Audio File First Aid: "Open in Wave Editor"
* Audio File First Aid: repair is done in the background for long files
* Audio File First Aid: progress "curtain" will block out further input without blocking the rest of the app
* Audio File First Aid: an added treatment for dealing with incorrect IFF chunk pads
* Audio File First Aid: fixed an issue writing analysis when it shouldn't have been
* Audio File First Aid: fixed an issue fixing one file of split files with unrecognized chunks
- improved disk/memory management for very large files
- fixed a memory leak when pasting
- fixed some bugs writing very large IFF files (AIFF & WAVE)
- fixed a hang after receiving an SDS dump
- added a "none" item to Preferences > MIDI > Input Port: to avoid some confusion
- fixed an issue opening some split surround files
- fixed playback sometimes stopping when the audio hardware changes or sample rate changes
- fixed an issue that might make sounds louder for a short period when the playback head moves unexpectedly
- improved the behavior of removing a range from a smart edit that has an end fade
- fixed an application error when using the recorder with a device with >32 channels
- fixed an issue with Autoplay in the Open panel
- fixed a volume issue with particular effects in non-native channel situations
- fixed a minor bug importing files by dropping on the app icon
- fixed an application error opening Support while running 10.4
- fixed a bug with the Smart Edit playback head
- fixed a bug with the Labels table and the Playback Loop column
- fixed an issue where standard WAVE files would show as ACID files in the Finder
- fixed an issue where standard AIFF files would show as Apple Loops files in the Finder
- fixed an issue flattening a fade
- added an alert when no labels are available for export
- fixed an issue with the Key/Root Note popup in the Inspector
- fixed an issue flattening a fade
- added an alert when no labels are available for export
- fixed an issue with the Key/Root Note popup in the Inspector
- fixed a rare occasion where CD-TEXT would not be exported via DDP
- fixed an issue where templates based on bars|beats might freeze new documents
1.4.5b2 Nov 14 2008 Download
- reduced situations that would cause dropouts on playback
- fixed a situation that would cause centered austoscroll behavior from the edge of the left margin
- further improvements to Support > Versions
- fixed an issue validating plugs on PPC
- fixed an issue playing back with Playback Loop selected when there are no loops
- fixed a rare bug when re-applying a VST effect
- improved situations where the app is processing and the app is hidden might disable the app after the process is complete
- fixed an issue flattening with VSTs and non-native channel counts
! a few lingering issues with SDS
1.4.5b1 Nov 11 2008 Download
+ Preferences > General > Processing: Use dither (adds Type II dither appropriately when processing or writing)
+ Cue labels (for Flash)
+ support for cue point XML files for the Flash Video Encoder
+ native support for Wave64 files
+ Preferences > Document > Display > Waveform Animation option
+ Import support for voXover files
* Enhanced Support > Screencasts
* Improvements to Audio File First Aid: drag & drop files, "Open in Wave Editor"
* Support > Release Notes changed to Support > Versions
* more Extend Selection To... commands in Keyboard Shortcuts
* hold down 's' key during start up to skip effect validation
* hold down 'v' key at startup to re-validate all effects
* Labels display options: Options... button in Labels drawer
* Labels display options: View > Options > Labels...
* Labels display options: new layer display method - Current Layer
- fixed the RSS URLs in Support
- fixed an issue with the waveform display in the Recorder
- fixed a bug cancelling import when all other import methods fail
- fixed an app error editing a SmartEdit while editing its name
- improved behavior dragging SmartEdits off the end of a file
1.4.4b6 Nov 03 2008 Download
- fixed an display issue after merging a SmartEdit that was last in the list
1.4.4b5 Nov 03 2008 Download
* disallow burning of discs that don't have enough space for the tracks
* improved playback and response of small loops
* improved reverse playback
* preference for anti-click playback on start and/or stop
- fixed some weird behavior with playback loops
- fixed some rare playback issues where the volume would be louder for a brief moment
- turned off zoom animation when using the zoom slider
- fixed issues saving parameters for some VST plug-ins
- updated MIDI icon in Preferences
- fixed an issue collapsing discontiguous smart edits after a delete

1.4.4b4 Oct 28 2008 Download
- fixed a bug opening documents that were already open within other documents
- fixed dragging items from the Master Layer
- fixed a bug saving new multi-channel files as Sound Designer II
- fixed issues where the progress panel might not close properly
- the MD5 file written from DDP exports is text instead of binary
- fixed a rare app error changing the color of a layer
- fixed a rare app error copying a smart edit
- fixed an application error with some Audio Units with unique descriptions
- fixed a small issue that could write WAVE files with more than one AFmd chunk
- fixed some issues with copy/paste smart edits
- fixed an app error when merging
- fixed an app error at the end of CD burning
1.4.4b3 Oct 27 2008 Download
* completely redesigned method for validating Audio Units and VST plug-ins
* hold down shift-command-option at launch to disable plug-in validation
* plug-in validation logs in ~/Library/Logs/Audiofile
1.4.4b2 Oct 22 2008 Download
- external links in the manual will forward to the default browser
- updated to libvorbis 1.2.0
- tempered the ability to Load... an already open document
- tempered the ability to Analyze while the Master Layer is selected
- the Analyzer panel frame is properly recalled
- fixed Hide Extension in the save panel
- fixed some bugs with VST support
- fixed the display of the selection area or insertion point when an empty layer is selected
- fixed a spurious error when attempting to configure an input device which has no configuration app
1.4.4b1 Oct 21 2008 Download
* added Preferences>Schemes for customizable split-file scheme support
* moved manual activation to a button in Support>Licenses
* support for Digidesign's 'regn' region extension to WAVE and AIFF files
- fixed some rare app errors when clicking on a Color Panel
- fixed and improved exporting & loading cue sheets
- fixed a rare visual bug when loading from other files
- fixed issues after removing an ISRC code
- fixed an issue importing DDP files with empty (0x00) strings
- fixed a bug with show/hide labels via keyboard shortcut
- fixed a bug recalling the Subtract layer combine type from .wedt files
- fixed the drawing of very small SmartEdits
- ignores Application Errors as a result of corrupt Address Book databases
- fixed the reading/writing of marker and region names for CAF files
- fixed a display issue with PQ Sheets
- fixed a bug undoing/redoing/undoing after a Flatten All
- fixed a bug where drags within the same .wedt file would be considered links
- fixed issues dragging SmartEdits from one channel to another
1.4.3b4 Oct 15 2008 Download
- fixed an error opening Audio File First Aid on Tiger
- potentially fixed a rare bug launching on PPC G5 machines
1.4.3b3 Oct 13 2008 Download
* safeguarded from sending more than one Support request at a time
1.4.3b2 Oct 12 2008 Download
- fixed a drawing performance issue when centered Autoscroll and the Overview are active
1.4.3b1 Oct 12 2008 Download
- improved SmartEdit drawing
- improved window resizing when background documents are playing
1.4.2b2 Oct 09 2008 Download
- fixed some minor issues in Audio File First Aid
1.4.2b1 Oct 08 2008 Download
+ Audio File First Aid
* added Magnitude and Min/Max to the Waveform menu
* settings in Export... panels are remembered
* cmd-[ and cmd-] navigate in the Manual
* added compound edit actions to waveform contextual menu
* Improved the Manual toolbar
- improved speed of zoom in using the scroll wheel
- fixed a potential app error in the Open panel
- fixed errors loading some Cue sheets
- "Format" tab is first in the Save panel
- fixed an error dragging an unselected SmartEdit to a separate empty document with the SmartEdit List open
- fixed a bug sending a HelpDesk request with no phone number
- addressed other application errors
1.4.1b2 Oct 06 2008 Download
* added a 320kbps option for AAC export
- fixed spurious application error opening manual on Tiger
- removed the Help menu in Tiger
- fixed triple-clicking action to select entire channel
- fixed an error command-dragging selections to the Finder
- improved issues starting up while validating plug-ins
1.4.1b1 Oct 04 2008 Download
* improved validation of VST plug-ins
1.3.0rc15 Dec 01 2007 Download
- fixed a potential crash closing a document while playing
- fixed dragging license activation files onto the dock/app icon
- fixed a visual artifact deleting labels from background layers
- fixed an issue with autoplay in the Open panel
- fixed an application error with "move selection to next zero cross" when the master layer is selected
- stopped the mistaken ability to flatten a fade while on the master layer
- restricted playback during changing sample rates
- removed the LAME framework from the bundle (requires user install)
- fixed a bug dropping an AU from a layer onto the name of the layer
1.3.0rc14 Dec 01 2007 Download
- fixed a crashing bug attempting to read malformed split WAV files
- protected against an application error when double-clicking on a keyboard shortcut group
- fixed a bug writing a flat .wedt file (affected "save selection as"... and drag/drop to Finder)
- fixed a bug with the grid & time units after saving newly as an Apple Loop file
- protected against a rare application error on paste
- improved option-dragging the volume slider for small volume increments
- fixed a rare issue with playback when the master layer is selected
- fixed an issue redoing color changes on a layer
- fixed an issue flattening a single layer of a multi-layered document to a new document
1.3.0rc13 Oct 18 2007 Download
- better default positions for panels
- fixed a bug trying to adjust trim levels on an empty document
- more thorough support for Sassafras licensing
- fixed some bugs relating to the grid
- fixed an issue saving a .wedt file with a layer name that includes a forward slash
- fixed a memory leak
1.3.0rc11 Sep 28 2007 Download
- updated handling of exceptions
- fixed a user miscommunication after silently repairing a file on open
1.3.0rc10 Sep 25 2007 Download
* added support for ProTools-style surround extensions
- fixed some errors writing DDP files
- fixed a cosmetic issue with sample dots at high zoom levels
- fixed a bug selecting a range in the master layer with snap to zero cross
- fixed a bug selecting the Key musical property
1.3.0rc9 Sep 14 2007 Download
- fixed an issue attempting to flatten all while the master layer is selected
- fixed a bug with Insert Silence with bars|beats if the tempo/time signature was not defined
- fixed a particular fade shape that would click & disable audio
- fixed the attempt to use the processor on an empty layer
- disabled some edit commands for empty layers
- removed some spurious console messages
- fixed an issue attempting to open the AU editor for fades
1.3.0rc8 Aug 07 2007 Download
- fixed a bug with automation position after removing SmartEdits
1.3.0rc7 Aug 01 2007 Download
- fixed an issue where Flatten Layer would always change the layer to Wave Editor format
- fixed several issues writing DDP files
! known issue with the location of a fade after removing SmartEdits
1.3.0rc6 Jul 28 2007 Download
+ AC3 import
+ if the app crashes, the next launch will ask the user if they want to report it via the HelpDesk
- fixed a bug referencing the proper pane in the HelpDesk from the Help menu
- improved some behavior in the Keyboard Shortcuts panel
- fixed a bug that might click during looping playback while changing selections
- fixed a small bug in the labels metadata table display
- improved some behaviors in the label drawer
- fixed a flashing menu item bug
1.3.0rc5 Jul 27 2007 Download
- fixed a bug sending a crash report in the HelpDesk
- fixed potential bugs saving files
1.3.0rc4 Jul 23 2007 Download
- fixed a snap adding a fade if the file had not yet been played
- fixed a rare playback/flatten freeze
- fixed a rare occurence of a click at the beginning of a cubic fade
- fixed a potential crash on an error moving a file
1.3.0rc3 Jul 20 2007 Download
- fixed an issue where the waveforms might not update after saving
- fixed some playback/loop issues
- fixed a rare bug where the user could select a negative range
1.3.0rc2 Jul 19 2007 Download
- fixed some flashing of the position tip when dragging range handles
- fixed an issue with some files created by Adobe products
- fixed an issue with playback on PPC machines
1.3.0rc1 Jul 19 2007 Download
- improved automation response during looping
- fixed a playback bug if a playback loop was after a selection and "Play Selection" was chosen
- improved graceful alerts when saving fails
- fixed a freeze when loop points were quickly brought together during playback (loop length was zero)
- fixed a bug that would occasionally "honk" loudly on starting playback
- allowed Undo for the Copy To... command
! dragging range handles: tip balloons will sometimes "flash" if dragged off the edge of the visible waveform while scrolling
! files created by Adobe SoundBooth don't open (thanks for butchering file formats Adobe!)
1.3.0b25 Jul 11 2007 Download
- fixed an issue looping a secondary layer with automation that's shorter than the total file length
- improved fade handle clicking and dragging
- fixed a bug modifying SmartEdits with no name in the SmartEdit list
- fixed a bug with cubic fades that might disable audio output
! occasional "honk" on open file, initial playback, or CD burn
! small click at the beginning of a loop on layers with fades
1.3.0b24 Jul 09 2007 Download
* improved meter CPU usage
- fixed an issue deleting empty space at the beginning of a file
- fixed a bug when importing wouldn't work
- fixed a crash attempting to play an empty file that had just removed all SmartEdits
- fixed an issue normalizing selections that are whole channels
- fixed an issue displaying the ruler on a newly created document
- fixed an issue that could remove audio when new audio pasted at the end
- fixed an issue saving loops in AIFFs
- improved the "removed labels on pasting at a label position" issue
1.3.0b23 Jun 27 2007 Download
* improved playback performance in some situations (loading of playback buffers done in separate thread, not main thread)
- fixed an issue with silence at the beginning of offset non-primary layers
- fixed a bug writing broadcast WAVE headers
- fixed a bug writing WAV files with odd-sized data
- fixed a suprious error reading some iXML data
- fixed a bug writing/reading AIFF marker chunks in certain circumstances
- fixed an issue where burned CDs might have stutters or dropouts
1.3.0b22 Jun 19 2007 Download
* added a progress panel for the generator
- improved behavior when adding loops to the playback head during playback (when a new loop is added, it automatically becomes the current playback loop)
- fixed an issue launching from a non-admin user
- fixed an issue saving loops in AIFF files
- fixed an issue changing the output converter during playback
- fixed an issue playing to the end of a file after a playback loop
- fixed a bug that would turn disabled AUs back on when adding a new AU
- fixed an issue using Save As, starting with a .wedt file and then choosing SDII
- fixed a cosmetic issue exporting or saving a selection from an unsaved file
- fixed an issue dragging a region of empty space
- fixed an issue where fades are effects wouldn't flatten completely
! everyone be sure keyboard shortcuts work as expected
! PLEASE TRY TO REPLICATE YOUR PREVIOUSLY REPORTED CRASHES
1.3.0b21 Jun 13 2007 Download
+ added "Range Type" (Integer/Floating Point) to the info bar
* internally improved Keyboard Shortcuts engine
- fixed a bug undoing back to an empty file or layer
- fixed a bug with a click at the beginning of a process in stereo files
- fixed a bug playing the very very end of a file
- fixed a bug looping a file with an empty layer
- fixed a bug looping with shifted layers
- fixed a spurious alert with regard to track ends before burning
- fixed a bug with "cut to layer..." from the labels drawer
- fixed a bug not using the window template built into a .wedt file when using the Open panel
- fixed a small display bug when removing the last layer
- fixed a bug reading markers from a SDII file
- fixed the ability (incorrectly) to save SDI and SDII formats as floating point audio
- fixed an issue dropping a range label near the end of a file
- improves keyboard shortcuts working with tables
- fixed a bug dropping a silent SmartEdit onto a new document
- fixed an issue inserting silence as a SmartEdit
! everyone be sure keyboard shortcuts work as expected
! PLEASE TRY TO REPLICATE YOUR PREVIOUSLY REPORTED CRASHES
1.3.0b20 Jun 07 2007 Download
* improved text fields in Processor
* selection ranges are choked to the start and end of the file
- FLAC exporting supports 4-, 8-, 16-, 20-, 24-bit
- fixed some bugs changing loops during playback
- fixed an issue reading split files with slightly different sizes
- removed AAC export at 320kbps (not supported)
- fixes and issue with "cut in place" (and "cut to new layer") and labels
- fixed a bug opening files with unfound AUs
- potentially fixed a rare crash on quit
- fixed a bug automatically selecting the master layer after deleting an AU on a secondary layer
- fixed a bug entering values in the Processor>Speed>Tempo fields
! PLEASE TRY TO REPLICATE YOUR PREVIOUSLY REPORTED CRASHES
! We believe we located a memory bug that affected a LOT of parts of the app, including playback, CD burning, writing DDP, and possibly flattening. It may also have fixed a lot of noises we've been experiencing on playback, including snapping, "fitzing", "honking", etc.
1.3.0b19 May 26 2007 Download
- fixed a bug with flatten
1.3.0b18 May 23 2007 Download
- improved stability with processing during playback
- fixed a gui issue removing audio at the end of a layer
- fixed a bug making new "copy to>" and "cut to>" documents appear as changed
- fixed an issue where the "paste multiple" panel was appearing when it needn't be
- fixed an issue save a selection of a .wedt file as a .wedt file
- a handful of small GUI fixes
- fixed an issue where CDs would not burn (framework was in test mode)
1.3.0b17 May 06 2007 Download
- fixed a mislabeled item in the columns popup in the Edit List table
- fixed an issue with AUConverter
- fixed an issue with shifting layers and labels/fades
- fixed an issue with extended characters and specific file contents
1.3.0b16 May 05 2007 Download
+ Selection range handles in waveform bar
+ Follow Layer option
* improved location tips
* improved AudioUnit GUI editor
* slightly improved Keyboard Shortcuts GUI
* slightly improved new region naming technique
* more options for playback head/bar display (via Waveform Options...)
* added a preference for waveform focus click behavior
* cut/copy label in labels drawer while range matches waveform will copy audio & label
* cut/copy range in waveform view will include enclosed labels
* paste in waveform view, labels drawer or layers drawer will paste existing audio & label if found
* preference for pasting multiple items (audio/label/both/ask)
- fixed a bug flattening with empty layers
- should fix a bug crashing on closing a document
- fixed a bug with selections and the master layer
- added an alert if attempting to process on the master layer
- fixed many issues with the iZotope Resampler
- fixed a bug reverting the state of the Channels bar
- fixed a bug reverting the drawer open/close state
! odd bug when pasting audio+label to new, blank layer and moving the audio
1.3.0b15 Apr 24 2007 Download
- fixed HelpDesk "freeze" if crash log not found (looks in both available places before giving up)
- fixed processing bug ("freezes" at end)
- fixed an issue dragging fades that were too long for the destination document
- fixed an issue saving a range when the range was beyond the bounds of the file
1.3.0b14 Apr 23 2007 Download
+ Thresholds process has "At nearest zero cross" option
* addressed some issues with fades and editing of single channels
- fixed a few bugs pasting into a new document
- fixed an issue where flattening wouldn't work
- fixed an issue changing the key by a dramatic value
- fixed a bug playing back at 192kHz with AUs
- fixed a bug being able to export labels from a document
1.3.0b13 Apr 22 2007 Download
- fixed a few bugs with waveforms
- a few less unnecessary alerts with regards to AUs
! new iZotope resampler has some latency issues
1.3.0b12 Apr 19 2007 Download
* ReCycle files are now available via Import (instead of Open...)
* ReCycle files have full metadata reading support
* add more error checking for memory errors
* bigger default window size (golden ratio!)
* label detail pane is open a little by default
- added error alerts if trying to speed process a file with illegal parameters
- fixed a bug selecting the proper layer after an "(edit) To Layer..." command
- fixed a bug with new flattened to... documents that wouldn't play
- fixed a bug that forgot the playback loop when saving to a flat file
- fixed a bug with the last few AUs crashing on flatten while GUI is open (Ozone, Spectron...)
- fixed some unusual memory stability bugs
1.3.0b11 Apr 10 2007 Download
- fixed a bug with the Thresholds process (and possibly others)
- fixed unplayable documents when opened as multiple in one document
- fixed a bug where labels may end up with a "nan" position (dragging a label in the master layer with Snap to Zero on)
- fixed an issue displaying "-0.00" in labels
- fixed a bug flushing undo on revert
- fixed a bug complaining about saving a file required to be Wave Editor
- fixed a bug undoing a layer color change
- fixed a bug redoing a "Cut to New Layer" action
- fixed a bug with the "File Size" in the Info bar with large file sizes
! new iZotope resampler has some latency issues
! changing from Apple to iZotope resampler makes Wave Editor very sad
! iZotope resampler does not yet support 64-bit input
! iZotope Ozone 3 crashes when closing document if AU window open
1.3.0b10 Apr 05 2007 Download
* dramatically improved the speed of some processing functions
* improved label command-zoom
* improved layer playback synchronization
- fixed a bug with AUs in the master layer remembering their settings
- fixed an issue where after emptying a file of content nothing more could be added
- fixed an issue where labels on the edges of files would disappear on save
- fixed an issue where faders were named "AFFader"
- fixed a random crash saving a .wedt file
- fixed a pop when adding a fade to the master layer
- reduced the possibility of a click at the end of a fade when the sample rate of the file differs from the hardware or flatten output sample rate
! new iZotope resampler has some latency issues
! changing from Apple to iZotope resampler makes Wave Editor very sad
! iZotope resampler does not yet support 64-bit input
! iZotope Ozone 3 crashes when closing document if AU window open
1.3.0b9 Mar 30 2007 Download
* added support for Growl
+ "Add to iTunes Library" available in Save/Export panels
- fixed a bug dragging non-primary SmartEdits in the SmartEdit bar
- improved time estimation
- fixed a bug playing back at 192kHz
! still reports of clicks at fade ends
! iZotope resampler for output does not like channels > 2
! iZotope resampler does not yet support 64-bit input
! iZotope Ozone 3 crashes when closing document if AU window open
1.3.0b8 Mar 27 2007 Download
+ Export Selection> menu (for exporting waveform or label selections)
- fixed a crash redoing a Cut to New Layer action
- Advanced options in Processor>Convert Sample Rate>iZotope Resampler follow the last position of the quality slider
- improved Import... (everybody make a point to check this)
- improved error checking
- fixed a bug that may change playback speed when adding an AU during playback
- fixed a bug where new files weren't playable
! files do not play back when hardware sample rate is 192kHz
! still reports of clicks at fade ends
! iZotope resampler for output does not like channels > 2
! iZotope Ozone 3 crashes when closing document if AU window open
1.3.0b7 Mar 20 2007 Download
- fixed a bug writing selected labels with the same name
- removed SmartCrashReports
- fixed an issue displaying imported files when dropped on the app icon in the dock
- fixed some issues with disappearing waveforms
- fixed an issue undoing edits on layers with a start point > 0
- fixed an error saving/reverting .wedt files with AudioUnits in the master layer
- improved progress "countdown" saving .wedt files
! iZotope resampler for output does not like channels > 2
! iZotope Ozone 3 crashes when closing document if AU window open
1.3.0b6 Mar 15 2007 Download
- fixed a bug where custom templates were very, very naughty and crashed the app
- fixed a bug where pasting audio into a new document results in an invisible waveform
1.3.0b5 Mar 14 2007 Download
- fixed a bug saving/opening a file with an empty layer
- fixed a bug reverting (and saving, which uses revert)
- fixed a bug pasting from a file who's source is a temp file
- fixed the insert panel
- recorder enabled channel settings are saved
- fixed an issue reading SoundTrack Pro files
- fixed burning and writing DDP of mono files
1.3.0b4 Mar 03 2007 Download
+ brand new licensing system
* Licenses (was registration) moved to Help Desk
* more Help Desk improvements
- fixed garbled Processor window
! crash on revert
! export as FLAC for large files is hosed
1.3.0b3 Feb 23 2007 Download
+ FLAC import/export
+ complete overhaul of Undo
+ added new Undo preferences (Preferences > General)
* added advanced options for iZotope converter in Processor
* DDP and CD-TEXT are now complete
* Keyboard Shortcuts are now searchable
* general speed and reliability improvements
* more Cocoa-ization of internals
* Help Desk is now resizable where necessary
! Processor interface is garbled (already fixed for 1.3.0b4)
1.3.0b2 Feb 01 2007 Download
* uses new CocoaStream routing engine
+ integrated Help Desk
- fixed pops at start of fades, etc.
1.3.0b1 Dec 28 2006 Download
+ Master Layer
holds Audio Units that affect the whole document
holds labels (including Track and Index layers for CD burning)
+ Burn to Disc
using the setup of tracks and indexes in the Master Layer
uses the Tracks properties for CD-TEXT
uses the appropriate document properties for CD-TEXT
+ new Cut/Copy/Paste To commands
shortcuts for multiple edit commands
Cut/Copy/Paste to a new layer or a new document
Cut/Copy/Paste to an existing layer in a document (current or otherwise)
+ More Export types
Apple Lossless
document properties
document labels
DDP files (for mastering)
+ Flatten options
sample rate
number of channels
latency compensation
retain tail (w/maximum)
master layer inclusion options
label inclusion/conversion options
destination options (new layer, new document)
+ Flatten individual fades
faster, will only process the area under the fade
+ Redesigned menus
+ redesigned Labels drawer
+ Support for VAG Time Format (28-sample boundaries)
+ Snap to > Time Units (will snap selections/labels/etc to the nearest time unit)
+ Playback latency compensation
* View>Bar Options...
* View>Follow
* improved progress panel when saving files with separate edits
* Layers, Audio Units and Labels can be dragged between documents and layers
* normal Edit Menu commands work on Layers, Audio Units, Fades and Labels
* more robust recognizing of split-channel (poly-channel) files
where C = channel name and xxx = extension, will recognize:
filename.C
filename-C.xxx
filename.C.xxx
filename.xxx(C)
* improved layer playback sync (now sample-accurate)
* Insert Silence option to add as a SmartEdit
allows extending the end of a file
makes silence measurements easier
* Open Panel improvements
can choose a template to open files with
can choose to open multiple files in a single new document
as overlapping or consecutive layers
as consecutive SmartEdits
as consecutive channels
* Save Selection To (replaces Save Selection As)
from a selection of audio or the selected labels
will use flattened audio if the master layer is chosen
* Save Panel improvements:
can choose to save as floating point if bit range >= 32
can optionally open after a Save To... action
* Export improvements
by default will flatten on export - not restricted to single-layer files anymore
can export just a selection of the current layer (will flatten if master layer chosen)
- fixed a bug redoing a layer move
- fixed a rare crash exporting as MP3 (WEWindowController_Export)
- fixed a crash reading some iXML WAVE files (AFAudioFileWrapper_Parse)
- fixed various other bugs
1.2.4rc2 Sep 20 2006 Download
+ "Play from Beginning of File" keyboard shortcut
+ Tempo guessing via the Inspector
* Improves saving of files ending in ".aiff" as opposed to ".aif"
* Improved opening of split files
* Import supports ID3 tags and other properties from file formats
* Export as MP3 writes appropriate ID3 tag elements from document properties
* Improved the "Insert Silence" panel
* Open panel allows multiple document selection
- fixed an issue with the repeat mode after a Save
- fixed a rare drawing bug
- fixed importing via dropping on the app icon
- fixed a bug in the display of the playback head in the Edit List after saving
- fixed a bug converting Markers or Slices to Edits
1.2.4rc1 Sep 06 2006 Download
+ integrated iZotope pitch/time in Processor
* minor interface tweaks
1.2.4b2 Aug 16 2006 Download
+ iZotope SRC options for both processing and playback (Preferences>Output)
+ "Pitch" process in Processor
+ "Dither" process in Processor (based on iZotope MBIT+ engine)
- fixed saving in place of split SDII files from becoming interleaved
- fixed a speed change when adding an AU to a file that is not the same sample rate as the hardware
1.2.4b1 Jul 26 2006 Download
+ Primary Layer is now moveable and removeable
+ Properties panel for editing metadata
+ Vertical scroll bar for waveform
* optimized playback (less CPU load)
* all metadata saved in all extensible flat file formats (AIFF, WAVE, SDII, CAF) including MIDI, musical, & others
* Loop Editor moved to separate utility app
* Improved software updating (using Appcasts)
* Improves interaction with Digital Performer
- fixed vertical ruler when waveform displayed as Average
- fixed a crash saving Apple Loop files on Intel CPUs