Audiofile Engineering
Wave Editor 1 Appcast
+ Added feature
* Improved/changed feature
- Bug fixed
! Remaining bugs and missing features
1.5.7 May 27 2012 Download
REQUIRES MAC OS X SNOW LEOPARD OR HIGHER

- resolved an issue where the AU Validator application would crash
- resolved an issue where exporting files with sample rates lower than 44.1 to AAC would not work
- resolved an issue where 32-bit files created by Max/MSP would not open
- resolved an issue importing dual mono SDII files
- resolved an issue uploading FLAC files to SoundCloud
- improved the interface for advanced options in the Processor
- resolved an issue where saving large wave64 files would cause an application error
- resolved an issue where the SmartEdits List would report the wrong channel count
- resolved an issue where Cut/Copy to New Document would not include removed audio at the start of the file
- resolved a rounding error when Flattening
- resolved an issue where compressed CAF files would open natively
- resolved an issue where illegal characters in DDP track names would generate an error
1.5.6 Feb 20 2012 Download
NOTE: This build requires Mac OS X 10.6 and an Intel processor. All future builds of Wave Editor are Intel-only. We will no longer be releasing Universal binaries of our apps.

- resolved an issue where non-native files would not import via drag and drop
- resolved an issue where copying and pasting a WAVE64 file would generate an application error
- resolved an issue where a file would not save if only the name of a layer was changed
- resolved an issue where "retain unrecognized data" would not function as desired
- resolved an issue where saving a .wedt file with fades as "efficient" would generate an application error
- resolved an issue where a song with no ISRC code in a DDP set would inherit the previous song's ISRC code upon import
- resolves an issue where holding down "s" at launch would not skip plug-in validation
- various bug fixes and improvements
1.5.5 May 10 2011 Download
* updated iZotope Resampler
- resolved an issue wherein playback produced overs under certain circumstances
1.5.4 Feb 14 2011 Download
- Resolved an issue skewing marker names in labels drawer
- Resolved an issue wherein DDP import corrupted EAN/UPC, ISRC, and track name data
1.5.3 Feb 07 2011 Download
- Resolved an issue summing channels
- Resolved an issue using MS Decode
1.5.2 Feb 04 2011 Download
- Resolves an issue flattening with fades on OS X 10.5
1.5.1 Feb 03 2011 Download
- Resolved an issue uploading files to SoundCloud
- Resolved a problem when performing a "Save To..."
1.5.0 Feb 01 2011 Download
DO NOT INSTALL THIS UPDATE IF YOU ARE RUNNING MAC OS X 10.4 (TIGER)

REQUIRES MAC OS X 10.5 (LEOPARD) OR 10.6 (SNOW LEOPARD)

+ Requires Mac OS X 10.5 or 10.6
+ SoundCloud support
- Various bug fixes
1.4.6 Jan 11 2010 Download
+ Added FiRe Browser (only works with FiRe 1.3+)
* Fully Snow Leopard compatible
* Improvements to importing AC3 files.
* made the window title of split file formats now show the extension as *
* recognized unusually-formatted 'cue ' chunks in WAV files
* added a "Configure..." button to Preferences > Output > Audio Output
* .wedt files and document templates will remember the width of
- Fixed an issue wherein MP3s would not import when dragged onto the application icon.
- Fixed an issue with new Layers causing playback issues.
- fixed an issue changing the Genre Code in Properties
- fixed an issue using ISRC codes with lowercase letters
- fixed an issue with unnamed tracks loaded from a cue sheet
- fixed a bug moving a SmartEdit from a non-left channel
- fixed an app error that would happen reading a malformed DDP file
- fixed some inconsistencies in writing Broadcast WAVE and iXML time references
- fixed an issue editing the sync time in a region
- fixed an error duplicating an empty layer
- fixed an error importing or loading multiple split scheme files
- fixed an issue with files that would open without a waveform
- fixed an issue with the Speed process working on entire files
- fixed an issue attempting to save an audio selection with master layer effects when a single layer is selected
- fixed an error in an alert when attempting to save a flat file with features of un-flattened files
- fixed cmd-opt-shift double-click on the non-selected waveform
- fixed subtle UI bugs in Snow Leopard
- fixed a rare crash when saving with effects on the Master Layer
- fixed some issues with time display
! removed import support for AC3 files due to licensing issues
- fixed an issue opening SDII damaged in a specific way
- Audio File First Aid: able to repair SDII files damaged in a specific way
- fixed some issues with MS Encode & Decode
- fixed an issue dragging links onto a new document containing only links
- fixed a bug flattening multichannel layers with effects
- fixed a few bugs with the Analyzer
- fixed an occasional app error changing crossfades during playback
- fixed a bug selecting the color of a layer while the Color Panel is open
- fixed a visual bug with the playback head on stopped playback
- improved drawing of SmartEdits when zoomed in extremely close
- fixed a bug updating the length in the Info Bar when the length of the audio changes
- moving SmartEdit handles when "Allow Separate Channel Selection" will move all channel-matching SmartEdits
- improved Location Tip positioning
1.4.5 Aug 12 2009 Download
+ Preferences > General > Processing: Use dither (will add the appropriate Type II dither to any processing or writing)
+ Cue labels (for Flash)
+ support for cue point XML files for the Flash Video Encoder
+ native support for Wave64 files
+ background analysis (Leopard only)
+ Chapter labels (for Podcasts)
+ Export > Podcast
* Import support for voXover files
* Enhanced Support > Screencasts
* Support > Release Notes changed to Support > Versions
* hold down 's' key during start up to skip effect validation
* hold down 'v' key at startup to re-validate all effects
* Labels display options (Options... button in Labels drawer, View > Options > Labels..., new layer display method: Current Layer)
* Properties import/export support for AAC, Apple Lossless and Podcasts (uses iTunes property set)
* Waveform selection contextual menus > Add Fade
* Layer table contextual menus > Add Effect
* Background color (replaces background brightness, overview draws using background color)
* Manual does not hide when app goes in background
* added a cancel button to the "paste multiple items" alert panel
* small improvements to the Keyboard Shortcuts panel behaviour
* small improvements to the Generator/Recorder/Meters panel behavior
* improved the Generator GUI
* improved the label well GUI
* small improvements to the selection area GUI
* time units are configurable in the Open panel
* added Logarithmic fades
* "CPU Load" item in Information Bar
* Information bar items can optionally show labels and units where applicable via contextual menu
* Preferences > General > Playback: Front Document Only which can conserve CPU load when many documents open
* more permissive in opening files that are damaged
* Audio File First Aid: drag & drop files
* Audio File First Aid: "Open in Wave Editor"
* Audio File First Aid: repair is done in the background for long files
* Audio File First Aid: progress "curtain" will block out further input without blocking the rest of the app
* Audio File First Aid: an added treatment for dealing with incorrect IFF chunk pads
* Undo is now faster
* more Extend Selection To... commands in Keyboard Shortcuts
* Preferences > Document > Display > Waveform Animation option
* improved loading files with content in the Master Layer into new or existing documents
- Audio File First Aid: fixed an issue writing analysis when it shouldn't have been
- Audio File First Aid: fixed an issue fixing one file of split files with unrecognized chunks
- numerous bug fixes
1.4.4 Nov 11 2008 Download
+ Preferences > Schemes for customizable split-file scheme support
* preference for anti-click playback on start and/or stop
* moved manual activation to a button in Support > Licenses
* support for Digidesign 'regn' region extension to WAVE and AIFF files
* significantly improved plug-in validation
* disallow burning of discs that don't have enough space for the tracks
* improved playback and response of small loops
* improved reverse playback
* updated to libvorbis 1.2.0
- fixed some rare app errors when clicking on a Color Panel
- fixed and improved exporting & loading cue sheets
- fixed a rare visual bug when loading from other files
- fixed issues after removing an ISRC code
- fixed an issue importing DDP files with "empty" strings
- fixed a bug with show/hide labels via keyboard shortcut
- fixed a bug recalling the "Subtract" layer combine type from .wedt files
- fixed the drawing of very small SmartEdits
- ignores Application Errors as a result of corrupt Address Book databases
- fixed the reading/writing of marker and region names for CAF files
- fixed a display issue with PQ Sheets
- fixed a bug undoing/redoing/undoing after a Flatten All
- fixed a bug where drags within the same .wedt file would be considered links
- fixed issues dragging SmartEdits from one channel to another
- http schemes in the manual will forward to the default browser
- tempered the ability to Load... an already open document
- tempered the ability to Analyze while the Master Layer is selected
- the Analyzer panel frame is properly recalled
- fixed "Hide Extension" in the save panel
- fixed some bugs with VST support
- fixed the display of the selection area or insertion point when an empty layer is selected
- fixed a spurious error when attempting to configure an input device which has no configuration app
- fixed a bug opening documents that were already open within other documents
- fixed dragging items from the Master Layer
- fixed a bug saving new multi-channel files as Sound Designer II
- fixed issues where the progress panel might not close properly
- the MD5 file written from DDP exports is text instead of binary
- fixed a rare app error changing the color of a layer
- fixed an rare app error copying a smart edit
- fixed an app error with some Audio Units with unique descriptions
- fixed a small issue that could write WAVE files with more than one AFmd chunk
- fixed some issues with copy/paste smart edits
- fixed an app error when merging
- fixed an app error at the end of CD burning
- fixed some unexpected behavior with playback loops
- fixed some rare playback issues where the volume would be louder for a brief moment
- turned off zoom animation when using the zoom slider
- fixed issues saving parameters for some VST plug-ins
- fixed an issue collapsing discontiguous SmartEdits after a delete
- fixed a display issue after merging a SmartEdit that was last in the list
1.4.3 Oct 22 2008 Download
+ Audio File First Aid
* added Magnitude and Min/Max to the Waveform menu
* settings in Export... panels are remembered
* cmd-[ and cmd-] navigate in the Manual
* added compound edit actions to waveform contextual menu
* improved the Manual toolbar
* safeguarded from sending more than one Support request at a time
- improved speed of zoom in using the scroll wheel
- fixed a potential app error in the Open panel
- fixed errors loading some Cue sheets
- Format tab is first in the Save panel
- fixed an error dragging an unselected SmartEdit to a separate empty document with the SmartEdit List open
- fixed a bug sending a HelpDesk request with no phone number
- addressed some random application errors
- improved SmartEdit drawing
- improved drawing speed during centered autoscrolling
- improved window resizing when background documents are playing
- various Help Desk fixes
1.4.1 Oct 07 2008 Download
* added a 320kbps option for AAC export
- fixed an application error generated when opening manual on Tiger
- removed the Help menu in Tiger
- fixed triple-clicking action to select entire channel
- fixed an error command-dragging selections to the Finder
- improved plug-in validation
- fixed an issue where moving VSTs between Layers would cause lock-ups
- fixed an application error when exporting DDP sets with ISRC codes
1.4.0 Oct 04 2008 Download
If you have many VST plug-ins, particularly older VST's, please use 1.4.1b1.

+ Native support for VST plugins
+ Export & Load Cue Sheets
+ Export PQ Sheet
+ Import DDP ("load-back")
+ Audio Units and VSTs that don't match channel counts can now be added
* many performance improvements with regards to editing & saving
* enhanced control, templates for saving documents
* Open multiple.../Load... can now also be as SmartEdits
* improved Recorder (more accurate marker/region placement, smoother waveform display)
* improved object dragging & autoscrolling
* animated waveform scrolling & zooming
* animated Info Bar texts
* improved SDS support, support for Elektron's Turbo MIDI
* support for FLAC metadata
* "Paged autoscroll margin" preference
* Added an "enter data here" hint in the Properties panel
* Added a "Clear" button to the Properties panel
* functional improvements to the PQ Sheet
* DDP export option to create MD5 checksum of the audio ("image.dat") file
* DDP export option to include CD-TEXT
* added an option to burn with/without CD-TEXT
* meters no longer freeze during menu selections, drags and open panels
* added warning for illegal ISRC and UPC/EAN codes when starting a disc burn
* made the size drag area of document bars work across the entire width of the bar
* Keyboard Shortcuts now support presets
* Help > Help Desk moved to Wave Editor > Support
* Manual now integrated into the application (Wave Editor menu > Manual)
* numerous minor performance improvements
- numerous minor bug fixes
1.3.3 Mar 08 2008 Download
* improved the Advanced Options for iZotope Resampler
- text boxes to fill in values
- command-click on slider will bring it to a default value
- active quality slider correlation
- presets
* preliminary support for Audiofile Engineering-brand USB dongles (available upon request for a small up-charge)
- fixed a rare crash opening documents
- fixed some rare display bugs while making selections in multichannel files
- fixed some erroneous "Application Error" reports when Universal Access is turned on
- a few small GUI improvements
1.3.2 Feb 12 2008 Download
* improved Audio Unit editor window placement
* Recorder and Generator panels stay open when app goes in background
* Added the ability to merge labels from the master layer during a Save To...
- fixed an issue copying from a Wave Editor file saved as separate edits
- restricted the ability to enter non-numeric characters in the Convert Sample Rate combo box
- fixed erratic behavior in the Recorder if chosen to open when it was already open
- improved layer naming when loading multiple documents
- fixed an application error when guessing tempo
- fixed an application error when clicking outside a label name during editing
- fixed a bug that blocked SonicFit (Pitch conversion) from working properly
- fixed an application error on Redo after removing all audio
- fixed a cosmetic error with the menu in the SmartEdit List
- fixed a bug attempting to slide the master layer
- fixed some noise flattening a fade while using iZotope Resampler
1.3.1 Jan 08 2008 Download
+ optional automatic detection of MIDI sample dumps
+ Export SDS (and Export Selection As SDS)
* Updated to latest version of FLAC library
* SmartEdits will retain their selected state across undo actions
* improved selection maintenance after deleting SmartEdits
- fixed the mistaken ability to load channels onto the master layer
- fixed a bug with some Flux plugs
- fixed the use of scroll buttons and wheel in the HelpDesk>Support>New Request text field
- fixed a compatibility issue with Full Keyboard Access
- fixed an application error if there was no Internet access
- fixed a cosmetic issue with the SmartEdit List
- (ability to accept URL commands)
1.3.0 Dec 12 2007 Download
+ Master Layer
+ Burn to Disc
+ new Cut/Copy/Paste To commands
+ advanced Flatten options
+ flatten individual fades
+ redesigned menus
+ redesigned Labels drawer
+ Support for VAG Time Format (28-sample boundaries)
+ Snap to>Time Units
+ Playback latency compensation
+ FLAC import
+ AC3 import
+ Support for Growl
+ "Add to iTunes Library" available in Save/Export panels
+ added "Range Type" (Integer/Floating Point) to the info bar
+ AC3 import
+ if the app crashes, the next launch will ask the user if they want to report it via the Help Desk
+ Selection range handles in waveform bar
+ Autoselect Layer option
+ Thresholds process has "At nearest zero cross" option
* Undo is greatly improved
+ Export: Apple Lossless
+ Export: FLAC
+ Export: document properties
+ Export: document labels
+ Export: DDP files (for mastering)
+ Export Selection> menu for exporting portions of a file
* View>Bar Options...
* View>Follow
* improved progress panel when saving files with separate edits
* Layers, Audio Units and Labels can be dragged between documents and layers
* normal Edit Menu commands work on Layers, Audio Units, Fades and Labels
* more robust recognizing of split-channel (poly-channel) files
* improved layer playback sync (now sample-accurate)
* Insert Silence option to add as a SmartEdit
* Open Panel improvements
* Save Selection To (replaces Save Selection As)
* Save Panel improvements
* Export by default will flatten on export - not restricted to single-layer files anymore
* Export can export just a selection of the current layer (will flatten if master layer chosen)
* metering improved
* Keyboard Shortcuts are searchable
* improved options for iZotope SRC in processor
* lots of minor interface improvements
* lots of various bug fixes
* added support for ProTools-style surround extensions
* improved meter CPU usage
* improved playback performance in some situations (loading of playback buffers done in separate thread, not main thread)
* added a progress panel for the generator
* internally improved Keyboard Shortcuts engine
* improved text fields in Processor
* selection ranges are choked to the start and end of the file
* improved location tips
* improved Audio Unit GUI editor
* slightly improved Keyboard Shortcuts GUI
* slightly improved new region naming technique
* more options for playback head/bar display (via Waveform Options...)
* added a preference for waveform focus click behavior
* cut/copy label in labels drawer while range matches waveform will copy audio & label
* cut/copy range in waveform view will include enclosed labels
* paste in waveform view, labels drawer or layers drawer will paste existing audio & label if found
* preference for pasting multiple items (audio/label/both/ask)
* addressed some issues with fades and editing of single channels
* ReCycle files are now available via Import (instead of Open...)
* ReCycle files have full metadata reading support
* add more error checking for memory errors
* bigger default window size (golden ratio!)
* label detail pane is open a little by default
* dramatically improved the speed of some processing functions
* improved label command-zoom
* improved layer playback synchronization
1.2.10 Dec 22 2006 Download
- fixed a bug with fades
- improved compatibility with AUs whose editor windows are open when flattening
1.2.9 Dec 14 2006 Download
* user definable scroll wheel actions (Wave Editor>Scroll Wheel Actions)
- fixed a potential rare crash exporting as MP3
- addressed some issues working with very large files
- fixed an issue saving 32-bit floating point AIFF and WAVE files
- fixed an issue reading 32-bit floating point AIFF files
- fixed an editing bug
1.2.8 Oct 31 2006 Download
* Keyboard shortcuts for Repeat mode (Keyboard Shortcuts>Playback>Set Repeat to...)
* minor improvements to the Processor GUI
* improved progress display saving .wedt files with separate edits
- fixed an issue recognizing the byte type of 8-bit ACID files
- fixed an issue deleting an area before existing crossfades
- fixed an issue with the Analyzer
- improved compatibility with Quicktime Player for AIFF files
- fixed a bug exporting AAC files on Intel machines
- fixed a crash launching as a non-admin user
1.2.7 Oct 11 2006 Download
+ Import/Export support for Ogg Vorbis files
- fixed a bug after closing files

Keyboard Shortcut additions:
+ "move selection to previous zero cross"
+ "move selection to next zero cross"
+ "extend selection to previous zero cross"
+ "extend selection to next zero cross"
+ fully channel independent
+ (known in other apps as "tab to transient" - but you can set it to any key)

1.2.6 Oct 09 2006 Download
+ Centered autoscroll option (View>Autoscroll>Off/Paged/Centered)
+ Stop action: can tell the playback head where to jump to when stopped (in Playback Bar contextual menu or options panel)
* support for horizontal scroll wheel movement
- fixed some internal errors with the display of the Software Update checker
- fixed an issue with changing speed with Apple's convertors
- fixed a few issues with AudioUnits
- fixed a bug with RX2 files
- fixed an issue with some AIFF files not being readable in other apps
1.2.5 Oct 04 2006 Download
+ internal support for iXML properties (will recognize and save the data to other formats, but not editable)
* properties are preserved during Save Selection As...
* more leniency previewing malformed files created with Ableton Live
* improved Apple Loop properties
* updated to LAME Framework 3.97
- fixed some confusion with the Properties panel
- fixed an issue removing an audio range right after a SmartEdit with a fade
- fixed an issue with AUTimePitch
- fixed a latency issue with the iZotope Resampler
1.2.4 Sep 30 2006 Download
+ Primary Layer is now moveable and removeable
+ Properties panel for editing metadata
+ Vertical scroll bar for waveform
+ "Play from Beginning of File" keyboard shortcut
+ Tempo guessing via the Inspector
+ iZotope SRC options for both processing and playback (Preferences>Output)
+ integrated iZotope pitch/time in Processor
+ "Pitch" process in Processor
+ "Dither" process in Processor (based on iZotope MBIT+ engine)
* Improves saving of files ending in ".aiff" as opposed to ".aif"
* Improved opening of split files
* Import supports ID3 tags and other properties from file formats
* Export as MP3 writes appropriate ID3 tag elements from document properties
* Improved the "Insert Silence" panel
* Open panel allows multiple document selection
* optimized playback (less CPU load)
* all metadata saved in all extensible flat file formats (AIFF, WAVE, SDII, CAF) including MIDI, musical, & others
* Loop Editor moved to separate utility app
* Improved software updating (using Appcasts)
* Improves interaction with Digital Performer
- fixed an issue with the repeat mode after a Save
- fixed a rare drawing bug
- fixed importing via dropping on the app icon
- fixed a bug in the display of the playback head in the Edit List after saving
- fixed a bug converting Markers or Slices to Edits
- fixed saving in place of split SDII files from becoming interleaved
- fixed a speed change when adding an AU to a file that is not the same sample rate as the hardware
- fixed vertical ruler when waveform displayed as Average
- fixed a crash saving Apple Loop files on Intel CPUs
1.2.3 Jun 19 2006 Download
+ Pre- and Post- roll playback control
+ Optional importing via Quicktime
+ Optional importing "raw" audio from files
+ Pitch Detection in Analyzer
* Preference for automatically opening document drawers when adding layer/audio unit/fade/label
* "Edit Blocks" -> "SmartEdits"
* "Erase" -> "Remove"
* SmartEdit commands available in Edit menu (e.g. Cut will cut either SmartEdit or selection, depending on latest user cmd)
* expanded/collapsed states of items in the Layers drawer remembered after save/on open .wedt files
* "Save" menu item is now available at all times, whether the document has a representation on disk or whether it was edited or not
- fixed a rare crash with the Recorder on Intel machines
- fixed an issue not locating a solitary template in the App Support directory
- fixed an issue opening files with fades on a machine with a different processor type than the original
- fixed some clicks at the beginning/end of quadratic/cubic fades in rare circumstances
- improved some cursor behavior with Pencil editing
- fixed updating the overview after Pencil editing
- fixed a crash choosing "Built-In Output" as an input in the Recorder
- improved fade quality on files that differ in sample rate from the machine's running rate
- fixed importing when app is in background
- fixed volume and varispeed from templates when importing
- fixed a rare crash on playback
- fixed some issues with humungous files
1.2.2 Jun 06 2006 Download
+ Added user options to add/save analysis data with files
+ Play from Selection Start & Play to Selection End actions in Keyboard Shortcuts
* added MS Encode to Channels bar, improved MS Decode
* added "follow selection" to the channels bar action menu
* activating a serial number will strip whitespace around it before attempting to activate (helpful for pasting from emails)
* improved increments in varispeed slider: option-click on either side of the knob (not the knob itself) will increment/decrement in intervals of 1c
* improved internal playback sample rate conversion
* improved utility window open/close response (can close by keyboard shortcut if in front)
- Loop Editor uses the chosen audio outputs
- fixed the selection after erasing to the end of a file/layer
- fixed a crash on quit if the varispeed or volume menu was open
- fixed a bug saving .wedt files with gain, invert phase, or active differences
- fixed a bug importing files on Intel-based machines
- other small bug fixes/improvements
1.2.1 Apr 01 2006 Download
- fixed issue with update checking
1.2.0 Mar 30 2006 Download
+ Channels bar
+ Waveform menu
+ Preferences>Document>Background brightness slider
* improved Label Well
* support for regions in AIFF files
* improved fade accuracy (esp. at very small lengths)

Enhanced MIDI playback (under Playback Bar options)
+ triggered/gated
+ note playback changes speed (standard "keyboard") or playback position (based on labels)

New text entry behaviour
- "." can be interpreted as general delimiter, replacing ":" as necessary
- not necessary to fill out all "fields" of multi-field formats
Example ("0:00.00" time format)
typing in "2" will become "0:02.00"
typing in "1.3" will become "0:01.30"
typing in "3..1" will become "3:00.10"
typing in ".32" will become "0:00.32"

* Keyboard Shortcuts: can clear conflicting keyboard shortcuts (option-clear)
* fade edges snap during drag
* improved .wedt file saving
* improved drawing performance
* improved MP3 support
* layer activation can change during playback
* support for tab and shift-tab in location bar S:E:L: editing
* improved progress panel's "Stop" button availability
* setting "allow separate channel selection" off will conform the selection to all channels right away
* retain highlighted column state in the Labels table
* disabled editing commands for RX2 files
* improved error handling when saving Wave Editor files
* improved drawing performance (cpu load during playback)
* changing bars and beats in an Apple Loop will re-calculate the tempo
* scroll wheel works in overview
* better support for files with industry-undefined channel counts
* prevents multi-channel files from being saved in SDI format (only supports single channels)
* improved Inspector display of items for empty layers
* improved the length format in the Generator
* revert will now also revert the window's state (size, bar position, etc)
* if linked file not found in original location, will try to find it in the same directory before asking user
* option-Open will treat bundles as directories (useful for GarageBand projects)
* now presents user with dialog if an invalid serial number was entered
- fixed some bugs in the Recorder
- fixed an issue that automatically closed Audio Unit editor window on undo
- fixed a potential for the Keyboard Shortcuts window to be always hidden
- retain highlighted column state in the Labels table
- aligned the note formatting with standard C3 as MIDI note 60 across the app
- fixed issues saving Apple Loop/ACID files
- fixed an issue that automatically closed Audio Unit editor windows on undo
- fixed attenuation of high frequencies when flattening high sample rate files
- fixed crash quitting the app when REX2 files are open
- fixed a rare issue losing playback on just-saved files
- fixed an issue "damaging" ACID files after opening
- fixed erroneous interleaved SDII file sizes
- fixed location bar updating when "snap to zero" is on
- fixed issue with playback head position during looping with a disabled layer
- prevented changing input channels on Recorder during recording
- fixed a rare Recorder crash when 'Done' pressed during recording
- fixed a potential freeze when removing all audio in a file with rulers on
- fixed a potential crash when accessing a corrupted SDII file
- fixed a rare crash exporting MP3s
- fixed wavetable accurracy issue
- fixed a visual bug duplicating layers with fades
- fixed an issue flattening all with a disabled primary layer
- fixed an issue playing/flattening a layer with a fade that had an inactive layer previous to it
- fixed saving files with layers with no audio
- fixed stability issue modifying edits during playback on multiprocessor machines
- fixed fade automation rounding error
- fixed a rare situation that would potentially overwrite files when saving audio between labels
- fixed updating the display of edit blocks after a flatten
- fixed edit list issues on non-primary layers whose start time is not 0
- fixed a bug dragging a whole fade
- fixed a visual bug selecting more than 2 consecutive channels
- fixed an issue not remembering values typed in the preference panel without hitting tab/return before closing
- fixed an issue freezing upon attempting to open malformed MP3s
- fixed the layer combine type names in the Inspector
- fixed not setting the volume upon opening a .wedt file
- fixed an apparent freeze flattening low-sample rate files with particular Audio Units
- fixed refreshing the waveform when undoing a flatten with retain tail
- fixed an issue with time display
- fixed a cosmetic bug with the Processor (from b9)
- fixed an issue changing speed with selection on less than all channels
- fixed an issue saving documents with empty layers
- fixed an issue saving files on Intel-based machines
- fixed a reset of a .wedt document volume after saving
- fixed a memory leak in drawing
- improved drawing (drawVRuler respects updateRect)
- fixed Save Selection As... recognizing the chosen bit depth
- fixed a bug writing RMS/Mean wavetables on save
- fixed updates of the overview on particular edit actions & dropping
- fixed offset dragging onto an empty channel
- fixed an issue with Intel-based machines
- fixed some issues with layers with channels at least greater than 2
- fixed small interface issues with empty layers
- fixed bar display bug (overlap/going over content bounds)
- (potentially fixed a crash on opening a document)
- fixed potential crash closing Loop Editor